Форум
 

Вернуться   Форум "Фрикер Клуб" - кодграббер своими руками > Основной раздел > Песочница

Важная информация

Ответ
 
Опции темы Опции просмотра
Старый 15.02.2018, 13:13   #11
heat Меню Пользователя
Член клуба
 
Регистрация: 12.10.2017
Сообщений: 151
По умолчанию Re: cc1101 и arduino - проблема с подключением!

у нас же уговор - он не пишет про попу . а мы не пишем в ветке . не надо так с админом . расстроится .
heat вне форума   Ответить с цитированием
Старый 21.11.2019, 07:33   #12
oleg Меню Пользователя
председатель клуба
 
Аватар для oleg
 
Регистрация: 01.01.2011
Сообщений: 636
По умолчанию Re: cc1101 и arduino - проблема с подключением!

Как вариант вижу Мини ПК, например Raspberry Pi, плюс Power Bank. Хотя возможно еще проще вариант, нужно знать, что гонит по USB на гаджет.
oleg вне форума   Ответить с цитированием
Старый 22.11.2019, 14:46   #13
legrand Меню Пользователя
Член клуба
 
Регистрация: 08.09.2011
Сообщений: 329
По умолчанию Re: cc1101 и arduino - проблема с подключением!

Цитата:
Сообщение от Braun
Да Олг, такая мысль у меня уже была. Если не удастся стартануть эти модули автономно попрашу внука установить на свой смартфон под управлением windows эту софтину SmartRF Studio7.

Вы себе четко представляете последствия использования глушилки в Евросоюзе?
legrand вне форума   Ответить с цитированием
Старый 09.12.2019, 17:25   #14
ArduinoS Меню Пользователя
Вступил в клуб
 
Регистрация: 24.01.2018
Сообщений: 41
По умолчанию Re: cc1101 и arduino - проблема с подключением!

Подниму тему. Очень хотелось бы узнать опыт бывалых. В общем, поигравшись с анализатором тахиона и приемом разных кодировок, забил на проект. Сейчас вот решил вернуться к нему и попробовать сделать отправку пакета.

Но никак не могу запустить передачу. В смысле передача то есть, но вместо ожидаемых ровных фронтов летит какой то мусор.

Делаю так

Цитата:
cc1101_strobe(STX); //переключаемся на передачу, кстати в передаче в конфиге patable 0xc0, остальные по 0x00
digitalWrite(CC_TX, HIGH);
delayMicroseconds(500);
digitalWrite(CC_TX, LOW);
delayMicroseconds(500);
digitalWrite(CC_TX, HIGH);
delayMicroseconds(500);
digitalWrite(CC_TX, LOW);
delayMicroseconds(500);
cc1101_strobe(SRX); //возвращаюсь к приему

Ожидаю два ровных импульса 500 us/500 us, но не тут то было. Может быть 2.5 ms на 8 ms, но никак не 500 на 500

Где может быть ошибка?
ArduinoS вне форума   Ответить с цитированием
Старый 10.12.2019, 08:03   #15
Бурый Меню Пользователя
Резидент клуба
 
Аватар для Бурый
 
Регистрация: 05.01.2014
Сообщений: 465
По умолчанию Re: cc1101 и arduino - проблема с подключением!

ArduinoS, как вы поняли, что импульсы не соответствуют ожиданиям? Вы снимали логическим анализатором (если он есть в наличии) либо осциллографом с вывода МК?

Может, перед передачей STX,, необходимо подать другую команду - SIDLE
__________________
Планировалось сделать "устройство"...и снова получились часы. Бой курантов тревожит двор)

Последний раз редактировалось Бурый; 10.12.2019 в 08:09.
Бурый вне форума   Ответить с цитированием
Ответ

Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.



Текущее время: 16:00. Часовой пояс GMT +3.


vBulletin 4.1.0 Перевод: zCarot
(C) www.phreakerclub.com
Яндекс.Метрика